Skip to content

Oracle LFI Advisory (CVE-2013-1525)

by on May 24, 2013

Product Information

Product: Oracle Retail
Application : Retail Integration Bus Manager
Affected Version: 13.0, 13.1, 13.2
CVE: CVE-2013-1525
Patch Information:
Discovered by: Andy Davies
Reported by: Andy Davies


Oracle provides retailers with a complete, open and integrated suite of business applications, server and storage solutions engineered to work together to optimise every aspect of their business. Top retailers worldwide use Oracle Retail solutions to drive performance, deliver critical insights and fuel growth across traditional, mobile and commerce channels.


A Local File Includes(LFI) vulnerability is present in the RIB-* web interface, which allows users to traverse the local File-System, and dump the contents of world readable files, or files owned by the oretailpr user/group.

Vulnerability Details


http://hostname:port/rib-sim-admin-gui/rib_adapter_logs.jsp?logFileName=../../../../../../../../../../../<LFI Here>




Reported 14/11/2012
Accepted: 27/11/2012
Fixed: 17/04/2013
Advisory Released: 24/05/2013

From → LFI, pentesting, pentura

Leave a Reply

Fill in your details below or click an icon to log in: Logo

You are commenting using your account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: